[Resolved] Red Button Craftsman 139-539-75-SRT1 not connecting to C-SP-390 remote.

Home Forums Compatible Remotes Support (C-SP-315, C-SP-390, C-IC etc) Red Button Craftsman 139-539-75-SRT1 not connecting to C-SP-390 remote.

This topic contains 4 replies, has 2 voices, and was last updated by   William 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #13624 Reply

    Lindsey

    My Crafstman 139-539-75-SRT1 red light will blink when I press the button on the remote but it will not open or close the garage door. Our remote is the C-SP-390.

    #13625 Reply

    Lindsey

    I should have mentioned that our Craftsman is a red button like the remote we purchased.

    #13626 Reply

    William
    Keymaster

    Hello,
    Sorry for the trouble, I just checked the model 139.53975 should work since it is Security+ 390Mhz system?

    Could you please send me your currently working remote’s model number?
    This is to 1) further confirm the compatibility 2) make sure your opener’s receiver circuit is good.

    Thanks.

    #13628 Reply

    Lindsey

    Sorry, we just bought the house and the remote they gave us is an off brand one with no visible model number even on the inside. It’s duct taped together….

    #13633 Reply

    William
    Keymaster

    Hi,
    In this case, just return our remote for refund.
    And check remotes from other suppliers, thanks.

Viewing 5 posts - 1 through 5 (of 5 total)
Reply To: Red Button Craftsman 139-539-75-SRT1 not connecting to C-SP-390 remote.
Your information: